Opened 12 years ago

Closed 12 years ago

#1196 closed task (invalid)

Ampersands in PRE tags are entitized and causing display problems for code snippets

Reported by: guest Owned by:
Priority: normal Milestone: 0.96
Component: HTML Output Version: trunk
Severity: normal Keywords:
Cc:

Description

I am trying to use Xinha within Drupal (via htmlarea) as a primary text editor and I am running into a problem where ampersands within the PRE tag are being turned into html entities, which causes them to literally show up as entities when displayed in html. Is there any workaround for this that is known? I have tried modifying the htmlencode function in the XinhaCore? (not my preferable solution) which took care of other entity problems I was having within PRE tags, but it does not work with ampersands. I have been spending hours on this and I can't find a solution, any suggestions would be most appreciated.

Change History (1)

comment:1 Changed 12 years ago by ray

  • Resolution set to invalid
  • Status changed from new to closed

It is absolutely correct to have ampersands escaped in pre tags, as anywhere in HTML. I suppose the problem is in Drupal, maybe those parts are post-processed and so doubly escaped

Note: See TracTickets for help on using tickets.