Opened 12 years ago

Closed 12 years ago

#1188 closed task (invalid)

Using Xinha in an Eclipse project

Reported by: guest Owned by: gogo
Priority: normal Milestone: 0.96
Component: Xinha Core Version: trunk
Severity: normal Keywords:
Cc: onno.van.der.straaten@…

Description

Hi,
I am considering use of Xinha in an Eclipse project. The Xinha license is compatible with the Eclipse Public License (EPL) I think, but to be able to use it, there is also the matter of 'provenance'.

Provenance is the origin or source from which something comes, Provenance and the history of subsequent owners (also known as Chain of custody in some fields).” (Wikipedia)

One way to track provenance is a contribution mechanism where there is a clear and consistent way to confirm that the authors of the code agrees to have their code distributed under the license. Is there such a contribution mechanism for Xinha?

If there is no clear mechanism, can we confirm who authored the code and their consent to have the code distributed under the license?

How did these authors contribute and agree to their contribution being used, is there an agreement, email confirmation, or something else?

Is there a small number of developers or are there many?

If there are a small number of authors, could we confirm provenance by having these authors answer few questions? could the Xinha project lead arrange that?

My request maybe creates some troubles but if Xinha is approved by Eclipse Legal it will be used by at least one but problably more Eclipse projects.

Thanks and Regards,
Onno

Change History (1)

comment:1 Changed 12 years ago by gogo

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug, ask in forums.

Note: See TracTickets for help on using tickets.