Opened 12 years ago

Closed 12 years ago

#1131 closed defect (invalid)

Double Space when hitting Enter

Reported by: guest Owned by: akaEdge
Priority: highest Milestone:
Component: Documentation Version:
Severity: blocker Keywords:
Cc:

Description

In IE,
You get Double space when you hit enter. We want to have the same functionality as MS word. I understand that hitting Shift+Enter will give you a new Line. Is there a way that we could change the configulation so when Enter is hit, it go to the next line instead of double line, or this is a bug in Xinha.

Email:frankieisme520@yahoo.com

Change History (4)

comment:1 Changed 12 years ago by ray

  • Resolution set to invalid
  • Status changed from new to closed

When you press enter a new paragraph is inserted, when you press Shif+Enter only a linebreak (<br />) is inserted in the current paragraph. This is just the same as Word does. If you don't like the space between paragraphs, use CSS to style the p tags accordingly.

comment:2 Changed 12 years ago by guest

The problem is if <p> is replaced with <BR/>, when a valid paragraph is entered in the Xinha Text Area by pasting the text from a word document, the paragraphs will be replaced by the linebreak, which is not a desired result. Is there a way to capture the key event of "Enter" to replace it by "Shift + Enter" in one of the Xinha Javascripts?

Thanks...

comment:3 Changed 12 years ago by guest

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:4 Changed 12 years ago by gogo

  • Resolution set to invalid
  • Status changed from reopened to closed

Not a bug, been discussed many times, search the forums.

Note: See TracTickets for help on using tickets.