Opened 9 years ago

Closed 9 years ago

#1120 closed defect (fixed)

HTML select overlaps color picker

Reported by: guest Owned by: gogo
Priority: high Milestone: 2.0
Component: Xinha Core Version:
Severity: major Keywords:
Cc:

Description

On IE6, when there is a HTML select below the editor, it overlaps the color picker when clicked opened. Workaround is to put a iframe underneath the picker.

http://www.google.com/search?hl=en&q=ie+select+iframe

kngan@…

Change History (4)

comment:1 Changed 9 years ago by ray

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this. The iframe solution is already implemented.

comment:2 Changed 9 years ago by wymsy

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have been able to reproduce this - sometimes. I see it in the extended example running on xinha.raimundmeyer.de, but not in the simple example and not in the extended example running on my development system (I don't have php on that, which might be a factor?) I suspect what is happening is that changeset:861 sometimes changes the positioning of the colorpicker from absolute to fixed, but does not change the iframe, so the iframe ends up in the wrong place. But as I said, I haven't managed to reproduce it on my development system yet. If I am right, the fix would be something like

this.iframe.style.position = this.table.style.position;

inserted at line 410.

comment:3 Changed 9 years ago by wymsy

I'm going to take back some of what I said in my last post. I'm not so sure that the conditional code in changeset:861 is being executed, so that may not be the cause (even though I still think there could be a problem there, because IE6 doesn't support position:fixed).

comment:4 Changed 9 years ago by ray

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed rev [936]

The insertation of iframe was limited to IE using conditial compilation, which is triggered using JS comments looking like this

/*@cc_on 
... IE only code ...
@*/ 

In our compressed release versions all comments are stripped, thus the difference between the example and the development system.


Note: See TracTickets for help on using tickets.