Opened 12 years ago

Closed 21 months ago

#1118 closed enhancement (fixed)

Firefox: Hitting enter makes text scroll away

Reported by: guest Owned by: gogo
Priority: highest Milestone: 2.0
Component: Xinha Core Version:
Severity: minor Keywords:
Cc:

Description

When I use xinha with firefox and I enter an amount of text that makes you scroll outside the text area, hitting enter will either make the cursor disappear (when at the bottom of the text), and reappear as soon as you type some text.

Worse, hitting, when somewhere at the top of the text, will make the cursor go to the top of the textarea and stay there, text is immediately scrolling out of sight.

This problem can easily be reproduced with the demo. With IE6 it works as expected.

Change History (8)

comment:1 Changed 12 years ago by guest

zinha_config.mozParaHandler does have some influence on the behaviour, but, it's messy. 'built-in' often gives a <br />., 'dirty' isn't ok and best gives often the above behaviour.

comment:2 Changed 12 years ago by guest

Looks like it's also most often with 'one' line paragraphs.

comment:3 Changed 12 years ago by guest

No, that last comment wasn't true.

comment:4 Changed 12 years ago by guest

This behaviour can be changed, when I press 'shift-enter'. It somehow toggles a variable(?). Now the editor scroll as expected for some time, until the 'situation' is triggered again.

comment:5 Changed 12 years ago by ray

  • Milestone set to 0.96
  • Resolution set to fixed
  • Severity changed from major to minor
  • Status changed from new to closed
  • Type changed from defect to enhancement

I'm not very confident that this can be solved...but we'll have a look later

comment:6 Changed 12 years ago by ray

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Changed 9 years ago by gogo

  • Milestone changed from 0.96 to 2.0

comment:8 Changed 21 months ago by gogo

  • Resolution set to fixed
  • Status changed from reopened to closed

[1340] I think will have fixed this (see #1600)

Note: See TracTickets for help on using tickets.