Opened 12 years ago

Closed 21 months ago

#1111 closed enhancement (wontfix)

VideoManager plugin?

Reported by: guest Owned by: gogo
Priority: high Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc: troy@…

Description

Hi Everyone,

I've been using Xinha for about two years now, it's great!

One thing that many users want right now is the ability to upload and/or embed video clips in various formats. Ideally this would work much like the ExtendedFileManager? or ImageManager? plugins. You could upload a video file (or provide a URL to a video file hosted elsewhere), different options would be presented based on the file format, and the end result is a W3C-valid html block and supporting javascript that loads the video into the page.

I've got some javascript that will handle Windows Media wmv's and Quicktime mov's. I have also done some work with an open source Flash video player that could be incorporated into this as well. One item that I'd like to implement on this plugin which I haven't attempted before (and may not be feasible) is to create gif animations from the uploaded video files for thumbnail preview purposes.

I'd like to collaborate with others on this, is anyone interested?

Thank You,
Troy

Change History (9)

comment:1 in reply to: ↑ description Changed 12 years ago by guest

Hi - just thought I'd let you know i've made some progress to this end, see http://www.jljsolutions.co.uk/xinha.html for a working example and download. It doesn't implement script versions yet - except for Flash I wasn't sure that script versions were 100% reliable for quicktime and wmv yet but I could be convinced otherwise?
let me know,
John

comment:2 follow-up: Changed 12 years ago by guest

Hi John,

This is great! I'm playing with it right now, trying to integrate OS FLV as another player. I don't want to stomp on what you've done to integrate JW FLV, I'll try to abstract that into a configurable option somehow. I'm also going to look into using that JavaScript? I mentioned to do javascript-driven insertion of the object and embed tags. I'd like to make it an option also.

The Quicktime version detection issue was solved by the awstats folks. I haven't looked at that code in any depth, but it might be instructive.

I did notice one bug in safari: When opening the file manager, it doesn't focus successfully and can't be brought to the front. I'll see what I can find out about that as well.

Very nice work! I'll try to get some kind of useful changes uploaded soon.

Cheers,
Troy

comment:3 in reply to: ↑ 2 Changed 12 years ago by guest

Cool! I'm not precious about JW FLV so stomp away! Fact is, I didn't know about OS FLV - this is obviously a better option being completely open source. I can't download the player at the second though (their site's down), does it have everything the JW player has including xml playlist functionality? I'm trying to implement uploading or making/editing playlists on the fly, so if the OS player has this option i'll design with it in mind instead.

That would be good if you could take on the script stuff - I'll try and have a look at that Safari bug also.

Thanks for the hand,
John

comment:4 Changed 12 years ago by guest

Hi John,

I investigated the Safari window focus issue last night, but no luck yet. I suspect that the problem is with EFM, not Media. Does EFM make an assumption that it is only opened when the user clicks on its button in Xinha's tool bar? I looked for a plugin that uses EFM from within a dialog and didn't find any, but my search was a late-night, bleary-eyed endeavor, not exactly thorough. Do you know of any plugin or contrib that does this already?

OS FLV doesn't have XML playlist support yet, maybe FLV Player is a better option for an open source player? Here's the "maxi" version, which is still an active project, and I believe has all of the features of the other, older versions:
http://flv-player.net/players/maxi/

But if not, looking at the "multi" version might reveal a solution:
http://flv-player.net/players/multi/

The approach you're using to swap the object/embed tags for an image placeholder is pretty cool. Took me a little while to figure that out, The edit tag plugin shows the image tag instead of the substituted object and embed tags. I'm not sure if that's desirable behavior, though. It helped me get my bearings in this instance, but probably isn't what the end-user should see if they select a media placeholder and hit the edit tag button. I'll add that to my list of things to look at.

Thanks!
Troy

comment:5 Changed 12 years ago by guest

The dialog on-top of dialog is also used in ImageManager? - when editing an image. But the same issue occurs in Safari, i've flagged it as an problem in another ticket. This should be sorted when the new dialog method is fully implemented (divs - not pop-ups ala lightwindow etc) then i'll steal the new method for Media.

That maxi player is good - i'll implement it instead of the JW for FLV/MP3 (if you don't get round to it) - it's only a case of changing the input names used for the flashvars. It doesn't have the nice playlist features that the JW player has but I envisaged the playlist feature as having it's own media category - so I'll still use the JW player for that.

Yeah i'm aware of the edit tag issue - it came in very handy for development, it's not a major issue but I think you're right.

comment:6 Changed 12 years ago by guest

Hey, Just thought I'd let you know I've added playlist functionality now if you want to check it out. Let me know if you managed to change/improve on anything.

comment:7 Changed 12 years ago by guest

Hi Troy - I noticed the dialog.js for EFM was updated recently and it conquers the issue in Safari, so I've updated accordingly. John

comment:8 Changed 12 years ago by guest

Hi John - Glad to hear about the dialog issue being resolved. Sorry I haven't been in touch, I wound up doing some XHTML cleanups instead of working on the player integration (#1179). I've been playing with the code you linked to, but the hardest part is not having it integrated with the main Xinha source. I was hoping to find a tagged version or branch in svn, but I'm not seeing one. Is this just on your machine only?

Cheers! Troy

comment:9 Changed 21 months ago by gogo

  • Resolution set to wontfix
  • Status changed from new to closed

With Youtube embed being prevalent etc, I dont' think this is necessary now

Note: See TracTickets for help on using tickets.