Opened 12 years ago

Closed 11 years ago

#1095 closed enhancement (duplicate)

FlashEdit plugin update

Reported by: guest Owned by: akaEdge
Priority: normal Milestone:
Component: Documentation Version:
Severity: normal Keywords:
Cc:

Description

Hello there, I wasn't sure where to put this, but - I had to make the unfinished plug-in FlashEdit? work for me - but I thought I may as well make it available for everyone. Feel free to make it better - I'm a javascript novice.

I've added:
the ability to add and delete swf movie files,
a display pane showing (and allowing selection of) all uploaded swf files,
and the ability to link (to each embedded swf file) the required Geoff Stearns' swfobject.js.
This in-turn will now pretty much work 'out-of-the-box' - however if a user will end up embedding lots of flash movies in one document it would be much better to leave this field blank and link to the script in the destination's header.

I had to make one change to the Xinhacore.js for this to work (it's just a novice's hack, I'm sure there's a better way of doing this).

line 2914 of the XinhaCore?.js file From:

if(!(/\.html$/.test(_1e0))) {

to:

if(!(/\.html$/.test(_1e0)) && !(/\.php$/.test(_1e0)) ) {

to stop it trying to append html onto the end of my php file. I don't know if this is a bad thing to do and will effect something else!

This plug-in will not take on a different skins (I don't have the time/will for fancy stuff) so I'll leave that to someone else.

Over to people more clever than I!

Attachments (1)

NewFlashEdit.zip (78.6 KB) - added by guest 12 years ago.
FlashEdit? Updated plugin

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by guest

FlashEdit? Updated plugin

comment:1 Changed 11 years ago by wymsy

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1097

Note: See TracTickets for help on using tickets.