Opened 10 years ago

Closed 10 years ago

#1055 closed defect (fixed)

v0.931 (2007-05-16) Stylist no longer context sensitive

Reported by: guest Owned by: gogo
Priority: high Milestone:
Component: Plugin_Stylist Version:
Severity: major Keywords:
Cc:

Description

The stylist plugin in v0.931 (2007-05-16) is no longer context sensitive, as seen in the distributed extended example.

Inappropriate styles (for other tags) are shown, when these styles are selected the text is wrapped with the other tags - which are not removed if the style is deactivated. This was also observed in the nightly build demo as of 31st July 2007.

If this is some form of new "improved" functionality, it seems counter-intuitive to me (and will no doubt confuse end users - especially those who are not fluent in HTML).

Change History (1)

comment:1 Changed 10 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

I'm not seeing any different beheviour to what Stylist has always done since I wrote it. However, what it did was incorrect all along in that it allowed the conversion and applicability of unsuitable tags.

For example in the extended example if the cursor was in a list item it would allow the application of h1.webdings_lvl_1 and in doing so convert the list item to an h1 (invalid!).

I have fixed this fault in changeset:870

Note that the ability to, for example, apply h1.webdings_lvl_1 to a p(aragraph) tag which converts that paragraph to a header, is correct, by design, and is unaffected by the changeset.

Note: See TracTickets for help on using tickets.