Opened 10 years ago

Closed 10 years ago

#1031 closed defect (duplicate)

xinha extremely slow in IE with bigger content, strange hack

Reported by: guest Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

Hello,

I'm using xinha editor, just downloaded version 0.93, in a custom content management system. It's working quite well.
However when I use xinha under IE7 with bigger content, let's say 8k, it loads noticeably slow.
When used with even bigger html code, let's say 18k, it loads for a couple of minutes at least. During these ~2 minutes my browser freezes and the cpu usage is 100%. On the other side it works really fast in FireFox?, no issues there.

Now, the strangest thing ever....

I have xinha with stripScripts=false;

If I use the same content, but starting with script tag, even an empty one like
<script></script>
the same page will load quite fast in IE7 ????

The same behavior can be easily simulates even in the online example. When using bigger content under IE and switch from text to html mode it works slow. However when we use <script></script> in the beginning of the content, it works fast.
It should be done with stripScripts=false, because otherwise the scripts tag will be romoved.

It will be extremely helpful if somebody finds a fix for this in xinha code, rather to place <script></script> in the html content itself.

Thanks

Change History (1)

comment:1 Changed 10 years ago by wymsy

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #1030

Note: See TracTickets for help on using tickets.